Jump to content
Server time (UTC): 2019-07-17, 15:41
Saunders

Bad Version, server rejected connection [FIX]

Recommended Posts

Bad Version, server rejected connection [FIX]

 

Make sure you only have 5 mods the server uses which can be found here, any mods from other servers must be unloaded. The mods must also be in a specific order as shown below.

5modslist.png.b463e57dfecacc6d2d99439e23a36c7b.png

 

Go to your Dayz launcher and right click the 5 mods and repair each of them.

 

RepairMods.png.fbf08857e6655a057c0892ede238a889.png

 

Go into steam library -> right click dayz -> properties -> verify integrity of game files

DayzSteamRepair1.png.0a5a7c43ada9facc2e6238cfc53508c4.png DayzSteamRepair2.png.ad49291a3540acfdf7e93446f0a72d93.png

 

Go into steam library -> right click dayz -> properties -> betas -> NONE - Opt out of all beta programs

BetaOPTIONS.png.4275ca679293011fbf1fc004cb5b1ff2.png 

 

Go into steam library -> right click dayz -> properties -> betas -> NONE - Switch to experimental, wait for it to download and then Switch back to None - Opt out of all beta programs

image.png.1424828d92f158a834203118546175c2.png ->image.png.0bc39dff76d0f35fdf847f0b42f4f1c1.png 

Congratulations you are now able to play DayzRP! 

Check out my This is not your active character [FIX] guide if you get this message after getting into the server

 

 

 

 

 

Share this post


Link to post
Posted (edited)

nice and simpel thats some good work however it didnt work for me did everything it the right order but still

bad version server rejected connection

Edited by Frank Castle

Share this post


Link to post

Sooo, if none of this works, what do you do?

Share this post


Link to post
2 minutes ago, EvanPVE said:

Sooo, if none of this works, what do you do?

It should work, do you have them in the correct order? Unload all mods and reload them (in the correct order). I've never met someone who hasn't had this work, they've said it hasn't but then turns out they redo it and it works. Let me know how you get on and you can come talk to me in Waiting for Staff Help if you'd like.

Share this post


Link to post
1 minute ago, Saunders said:

It should work, do you have them in the correct order? Unload all mods and reload them (in the correct order). I've never met someone who hasn't had this work, they've said it hasn't but then turns out they redo it and it works. Let me know how you get on and you can come talk to me in Waiting for Staff Help if you'd like.

Done it all.

Share this post


Link to post

same, cant get it to work after reloading in correct order, repairing, re validate. Could it be that when i validate it asks if i want to remove files, was i suppose to?

 

Share this post


Link to post

ok, problem was with using dayzsalauncer.  found another thread, have to use regular dayz launcher from steam.   

 

Share this post


Link to post

Thank you I will try this once I’m home from work hopefully back in the server tonight for some more great RAP

Share this post


Link to post
10 hours ago, Carl9 said:

Thank you I will try this once I’m home from work hopefully back in the server tonight for some more great RAP

Awesome! If you're still having issues after using the guide feel free to drop me a message and I'll be more than happy to assist you in whatever way I can

Share this post


Link to post

You can't use DayzSA. You must use the vanilla client @RootOfTheTree

Share this post


Link to post
Posted (edited)

on steamworkshop the mod dayzrp mod isnt showing will it be bac up soon?

Edited by tim D

Share this post


Link to post
Posted (edited)

did not work, and I used the vanilla launcher

Edit: I saw as this is a temporary problem, could I wait for the actual DayZRP mod to be back up on the workshop and then play? 

Edited by NoahsNoah

Share this post


Link to post

I had this issue yesterday @NoahsNoah. I did all the steps in OP, but in addition to this I opted to participate in the experimental beta, downloaded and installed that, and then opted out of it and installed the normal patch again. That fixed my problem.

Share this post


Link to post
36 minutes ago, FALL1N1 said:

DayZRP Mod is not on the workshop, what can I do?

Check the upper-right announcement box of the forums page

 

Here's a tutorial for the newest update

 

Share this post


Link to post
On 6/27/2019 at 9:59 AM, Hofer said:

I had this issue yesterday @NoahsNoah. I did all the steps in OP, but in addition to this I opted to participate in the experimental beta, downloaded and installed that, and then opted out of it and installed the normal patch again. That fixed my problem.

@Saunders

 

I have had two different players be unable to be fixed with what is in the original post, but what Hofer quoted here fixed the problem for both of them... After 2-3 hours of effort. Worth adding to the original post, IMO!

Share this post


Link to post
7 minutes ago, Rover said:

@Saunders

 

I have had two different players be unable to be fixed with what is in the original post, but what Hofer quoted here fixed the problem for both of them... After 2-3 hours of effort. Worth adding to the original post, IMO!

Yes, I do usually give this as a troubleshoot also. Good call to add this, does it look good now?

Share this post


Link to post
Just now, Saunders said:

Yes, I do usually give this as a troubleshoot also. Good call to add this, does it look good now?

Expeditious as always, looks good!

Share this post


Link to post

I was in game and having no issues then a disconnect. No worries this happens. However, when I tried to rejoin server one  I got the Bad Version error.  

I have verified all mods ( I only have DayZ RP mods)  are in correct order and Day Z mod is latest 19.7.2. I followed the recommended steps exactly three times.  As suggested above I also unloaded and reloaded mods prior to the fourth attempt. 

Beta Tab - Switch to experimental - DL of experimental completed.  Switch to None - DL of Day Z update completed.

This version image is what is displayed on the launcher.  Is this the correct version for the servers?  1197014607_DayZVersion.jpg.6b7cf2030db9b67865fc7903924f0a2c.jpg

I'll check back in the morning. Thanks in advance for any offered advice/assistance.

If the more proper way to attempt resolution is to contact a support team member please let me know.

 

* update - This morning login was successful. 

 

Edited by Berzerker

Share this post


Link to post
23 hours ago, Berzerker said:

I was in game and having no issues then a disconnect. No worries this happens. However, when I tried to rejoin server one  I got the Bad Version error.  

I have verified all mods ( I only have DayZ RP mods)  are in correct order and Day Z mod is latest 19.7.2. I followed the recommended steps exactly three times.  As suggested above I also unloaded and reloaded mods prior to the fourth attempt. 

Beta Tab - Switch to experimental - DL of experimental completed.  Switch to None - DL of Day Z update completed.

This version image is what is displayed on the launcher.  Is this the correct version for the servers?  1197014607_DayZVersion.jpg.6b7cf2030db9b67865fc7903924f0a2c.jpg

I'll check back in the morning. Thanks in advance for any offered advice/assistance.

If the more proper way to attempt resolution is to contact a support team member please let me know.

 

* update - This morning login was successful. 

 

This was due to the Summer_Chernarus mod being updated and unfortunately we had to wait for Roland to get online and update the servers so that they could work alongside the said mod update. 

Glad you got it fixed in the end and for future use it may be helpful for you to join the DayzRP discord and pop a message in the #help text channel for any further issues as you'll be sure to get a quick reply from one of our trusty support team members/fellow community members.

Have fun and stay safe out there fella!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...