Jump to content

Server time (UTC): 2022-08-15 12:45

Can't compile "world" Script Module


Rick

Recommended Posts

  • Emerald

I've been getting fine into the server for the past few days, but when I joined today, it gave me the following error below. 

If I launch the game without the DayZRP mod active, it works fine, so its tied to the mod somehow. I saw some had this problem before, but deleting the XML files from the DayZ folder in documents didn't work. Additionally tried the stock fixes of re-installing DayZ, verifying integrity of game cash, deleting and re-installing DayZRP mod, and using the mod repair function in the launcher, but nothing has yet to fix the issue. 

DayZ_x64_2019-02-04_16-44-07.png

Edited by Rick
Link to comment
  • MVP

Only workaround I found was delete all dayz relevant folders and reinstall the game. ?

Link to comment

I didn't have to go as far as deleting all relevant folders. Uninstalled dayz like you normally would on steam. Restarted my PC. Reinstalled and verified game cache while making sure to check the two boxes labeled user data and logs?

Something along those lines. I had to do this not only for that error but whenever I would get in game I couldn't move at all and couldn't even pull up the esc menu. This was my fix.

Link to comment
  • Emerald

And that would do it. Thanks Rolle 

Link to comment

I've tried the exact same methods, I'm getting this error too and it won't let me start up DayZ. Whenever I deactivate the mod it works without any issues, anything you guys recommend for me to do?

 

EDIT: Nevermind, I managed to fix this issue after having tried for hours yesterday. If you're experiencing issues with this try and force your DayZ launcher to connect to the DayZRP server immediately on startup. Simply go to parameters, client and then fill in the three boxes which say. server address, port and server password. Did it for me.

Edited by Mr Fantastic
Link to comment
  • 3 months later...

Ive tried all of the solutions suggested here and am still stuck with the issue. Does anyone know other solutions? My error goes exactly like this:

Can't compile "World" script module!

 

kuroakita\DayZPlus\Scripts\4_World/barricading_scripts\board_base.c(338):Multiple declaration of class 'Crowbar'

*Edit This is my first time trying to enter the server and have had no trouble connecting to others

Edited by Drunk Constantine
Further info
Link to comment
  • 6 months later...
  • Legend
26 minutes ago, GhostOx said:

hI, im having the same issue, ive followed every instruction i can find. ive got all the mods on. i cant figure out what to do to stop it crashing like this.

This is typically caused by the mods being in the wrong order.

Please join our discord and come to the #help channel or join the waiting for staff help voice channel. ?

Link to comment
  • 2 weeks later...

I seem to be experiencing the same issues. I usually launch my game from DZSA launcher but i could not find the server on there. I went on steam and loaded all the right mods and put the parameters for the server in and got hit with this message. I've reinstalled dayz and restarted my computer aswell.

EDIT: I uninstalled and unsubscribed from everything, i then had to validate the mods when i reinstalled because of the error below

 

 

Spoiler

221100_screenshots_20191217034551_1.jpg

 

Edited by Terriors
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...