Jump to content

Server time (UTC): 2021-09-20 20:12

Bad version?


Recommended Posts

I've got experimental .63 and it worked just fine for several days, but for the last two nights it has been telling me I have a bad version? What do I do to fix this? It seems like at every pass this game is trying its best to not have me play.

Link to comment
  • Legend

Have you downloaded the DayZ Launcher? You will need this launcher to download our mod and connect to our server. 

Link to comment
  • MVP
1 hour ago, Perfidus said:

I've got experimental .63 and it worked just fine for several days, but for the last two nights it has been telling me I have a bad version? What do I do to fix this? It seems like at every pass this game is trying its best to not have me play.

Hey Perfidus,

Are you 100% sure you have followed all of the steps below as stated in the guide made by @Sleepyhead? If not, please click here and check it out. You will need to download DayZ Launcher as Brayces stated and make a few other adjustments. If your problem persists, please come find a Support on Discord.

Edited by Semiazas
Link to comment
  • lukaszxe locked this topic
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...