Jump to content
Server time (UTC): 2019-10-24, 05:48
Sign in to follow this  
Otto

DayZ Crashing on RP Servers

Recommended Posts

So I recently have encountered this issue and so far I haven't been able to resolve it. Basically when I try to load into s1 or s2 as soon as my character begins to load in (screen is black and I see the direct communication appear in the bottom left) my DayZ will receive an error message and crash. This is a screenshot of the error:

http://puu.sh/sA4gA/806b49a2d8.png

The issue began two days ago. I was in s1 for about an hour and the server restarted. The error proceeded to pop up once I tried to log back in after restart. I tried logging in to s2  and experienced the same problem. I closed the game, verified my game cache and restarted, the error continued to occur. I have uninstalled and reinstalled twice and the error still occurred. Strangely, this only happens on the DayZRP servers as far as I know. I don't play on any other private hive servers so i haven't been able to test it there but I am fully able to load into and play on public servers.

 

I've looked up the issue on several support forums and there were suggestions about uninstalling a program called "Display Link" which I don't have. There were suggestions about turning off background programs, running certain things as admin, updating drivers, updating windows, updating directx, etc and all of those I have up to date or updated to no change in the problem. There was also a suggestion that perhaps it was bad ram, but I haven't had issue on any high performance game, and again I can play on the public servers with no issue. There were a few other things I tried I can't remember off the top of my head, but all in all I was wondering if anyone had any other suggestions before I make a post on the official dayz forums. Thanks.

Share this post


Link to post

I experienced this issue a bit. Often, it's when I am receiving a bad lag spike which forces the game to crash. Therefore, the error could surface from your systems being overclocked. When you run DayZ, do you have anything else running in the background?

Share this post


Link to post

Other than TeamSpeak not really no, I've tried just running DayZ itself and as I said previously there was a suggestion about turning off all background programs which I disabled all non-essential things through the start-up preferences. I don't see how this would be the issue though it's not like TeamSpeak stresses out my computer or strains connection.

Share this post


Link to post

Can you run task manager and pop to the processes tab and run DayZ at the same time and see what program is running at an abnormally high CPU/ memory consumption rate at the same time? Mine was the Steam Client Bootstrapper and performance became a lot better after I closed it (granted I couldn't use it in game anymore).

Share this post


Link to post

I just looked the only thing taking up the most memory is the game itself. The Steam Bootstrapper is taking up like 0.2%  CPU so, yeah.

Edited by Oceco Otto

Share this post


Link to post

Hey there

from what I can tell its a common error so I can't gather anything from that. Like Melvin said its usually something to do with memory usage. From what I can gather its more of a RAM problem over a CPU problem and since the DayZ client is only 32 bit at the moment and only utilises a certain amount of RAM, there isn't really that much that you can do. 0.61 is utilizing a 64 bit client so if you can't fix it you might want to wait until 0.61 when the 64 bit client rolls out.

Sorry that I can't help but this is just my speculation

Share this post


Link to post

Should be an easy one.

Hover over the game in Steam --> Properties --> Launch Options --> type in the box '-maxmem=4096' --> hit ok and it should be fixed.
I presume you have more than 4 gb or RAM so 4096 is good. if you have less replace 4096 with 2048.

Why do this only happen on RP servers? Alot more stashes and centralized loot, overcompensating your load and tries to access ''fake'' memory.
Go over the reasonable ammount set by DayZ's engine (6gb) and the game crashes.

You can and most likely will experience Tearing from time to time, these are the launch settings maxing out the ammount of RAM accessable.
Once it's ''calmed'' down the game should behave as normal again.

Share this post


Link to post

Thanks for the other responses. I tried what you recommended Chow and it appeared to work at first. I loaded in and I could actually see things load in and my character did the load in reloading animation and then after about I suppose 3 seconds my game froze. I tried it again and it has gone back to the old error pop-up upon loading in :/ 

Share this post


Link to post

I know we've talked over steam and tried trouble shooting the problem. It looks like an issue with a background program interfering with Dayz causing a memory leak, and being on the RP servers with oodles of stashes and people around its going to chew through more memory than a public server as chow had said.

Try out this guide i found on the Steam Support site. it may be the cause of this issue.

https://support.steampowered.com/kb_article.php?ref=1274-uohk-5653

 

Share this post


Link to post

I've done pretty much every one of those things that would apply to my pc with no change really. This is really ridiculous.

Share this post


Link to post

Hey there!

You still have the same issue? Or is it solved now? :)

Greetings, Lyca

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...