Jump to content
Server time: 2017-10-24, 07:41
Safe Zone: CLOSED

  • 0
Sign in to follow this  
ChilliVanilli

stream audio issue

Question

ChilliVanilli    65

so here is the problem, i have a new pc but now i have no ingame sound in my stream(also no ts sound) if my headphone are set on default device. i have only ingame sound in my stream if i use the speakers as default device. i tried many things to fix this, but nothing works. and YES my settings on obs or xsplit are correct :D   i hope someone can help me 

is it possible that the alienware audio software cause these trouble?

Share this post


Link to post
Share on other sites

33 answers to this question

Recommended Posts

  • 0
ChilliVanilli    65

To understand a bit better...You hear all PC sounds yourself? Are you only having trouble with recording audio?

the sound on my pc works normal, i have only trouble with my stream. my headphone are the default device and in my stream you hear only my voice, no ingame sound or ts communication

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

Make sure to run all your programs as Admin (teamspeak, your game, OBS) tell me if that helps anything.

thanks but that is not the problem :)

to clarify, i have ingame sound if i use my speakers as the default device, but i need my headphone as default device for my stream. 

speakers as default device = ingame sound

headphone as default device = no ingame sound, only my voice get recorded

Share this post


Link to post
Share on other sites
  • 0
Cow    0

Alright, a stab in the dark but have you tried re-installing it? Make sure to remove all traces of OBS first and I hear of issues with Anti-aliasing so whatever you do it's best to turn that off.

Share this post


Link to post
Share on other sites
  • 0
MapleMooses    0

Also if you think it's an issue with your alienware audio software (which can most definitely be the problem!) try to disable it then test out your recording.

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

Screen shot all audio devices that you see active please.

you mean from windows sound manager or from obs ?

Share this post


Link to post
Share on other sites
  • 0
MapleMooses    0

Screen shot all audio devices that you see active please.

you mean from windows sound manager or from obs ?

Windows sound manager.

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

Alright, a stab in the dark but have you tried re-installing it? Make sure to remove all traces of OBS first and I hear of issues with Anti-aliasing so whatever you do it's best to turn that off.

i tried obs classic /studio xsplit gamecaster/broadcaster, everyone is new installed and nothing works. anti-aliasing cause blackscreen trouble if you dont play dayz in windowed mod

Share this post


Link to post
Share on other sites
  • 0
Oliv    1890

I take it your headset is USB? Apologies if you already clarified and I missed that.

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

I take it your headset is USB? Apologies if you already clarified and I missed that.

yes its usb

Share this post


Link to post
Share on other sites
  • 0
MapleMooses    0

I take it your headset is USB? Apologies if you already clarified and I missed that.

yes its usb

Try disabling your alienware audio software.

Also try different USB ports.

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

Screen shot all audio devices that you see active please.

you mean from windows sound manager or from obs ?

Windows sound manager.

j6kqKbX.jpg

aiE6jki.jpg

1IJ0CFt.jpg

Share this post


Link to post
Share on other sites
  • 0
Oliv    1890

When I ran a usb headset, I had the same/similar issues. My stream and videos would pick up game sounds (default output set as desktop speakers), my voice (default input set as USB mic), but not my teamspeak (set to usb monaurul speaker).

If you want your team speak picked up, you are going to have to mix sound sources together using virtual cables, etc. I'm not quite sure how you have things set up, but thats what it sounds like to me.

A simple solution to get OBS to pick up your mic should be to set it to always capture or push to talk and use the same push to talk buttons for in game as PTT 1 and teamspeak for PTT 2 in OBS.

Now, I'm not sure exactly how your OBS is set up, but that's what it is sounding like to me.

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

thanks for the help but sadly nothing works for me. i try other speakers and headphone the next days, or maybe someone has another hint?

Share this post


Link to post
Share on other sites
  • 0
Skinner    506

Shouldn't your Razer Kraken USB headset be set to default device? That's the headset you use when playing dayz and streaming right? Try setting that in the playback tab in windows sound manager and click Set Default, then make sure OBS is set correctly to use that as your sound device. Should work.

Share this post


Link to post
Share on other sites
  • 0
MapleMooses    0

Shouldn't your Razer Kraken USB headset be set to default device? That's the headset you use when playing dayz and streaming right? Try setting that in the playback tab in windows sound manager and click Set Default, then make sure OBS is set correctly to use that as your sound device. Should work.

My Razer sound software for my headset is the one set for default.

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

Shouldn't your Razer Kraken USB headset be set to default device? That's the headset you use when playing dayz and streaming right? Try setting that in the playback tab in windows sound manager and click Set Default, then make sure OBS is set correctly to use that as your sound device. Should work.

it is my default device if im streaming, but i have no ingame sound in my stream. the signal stops instantly from desktop audio after i switched from speakers to headphone

Share this post


Link to post
Share on other sites
  • 0
Skinner    506

Shouldn't your Razer Kraken USB headset be set to default device? That's the headset you use when playing dayz and streaming right? Try setting that in the playback tab in windows sound manager and click Set Default, then make sure OBS is set correctly to use that as your sound device. Should work.

it is my default device if im streaming, but i have no ingame sound in my stream. the signal stops instantly from desktop audio after i switched from speakers to headphone

Are you doing this AFTER you launch the game? DayZ doesn't let you switch sound devices while the game is already open. If you change sound devices, you need to close and relaunch the game for the sound (or sound capture in this case) to work.

Share this post


Link to post
Share on other sites
  • 0
Oliv    1890

^ that is correct. DayZ will always use what is set up as your default device, both for playback and recording AFAIK, and it has to be set before you launch the game.

For shits and giggles, can you screen shot the audio settings in both steam and OBS as well?

Share this post


Link to post
Share on other sites
  • 0

the easiest way would be to mix the audio together using a virtual source and then pipe it into obs. That is how i run it and it gives me the ability to do all sorts of things to my audio.

Little old-school tutorial my friend made that might help mashing those audio channels together.

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

Shouldn't your Razer Kraken USB headset be set to default device? That's the headset you use when playing dayz and streaming right? Try setting that in the playback tab in windows sound manager and click Set Default, then make sure OBS is set correctly to use that as your sound device. Should work.

it is my default device if im streaming, but i have no ingame sound in my stream. the signal stops instantly from desktop audio after i switched from speakers to headphone

Are you doing this AFTER you launch the game? DayZ doesn't let you switch sound devices while the game is already open. If you change sound devices, you need to close and relaunch the game for the sound (or sound capture in this case) to work.

i know ;)


^ that is correct. DayZ will always use what is set up as your default device, both for playback and recording AFAIK, and it has to be set before you launch the game.

For shits and giggles, can you screen shot the audio settings in both steam and OBS as well?

trust me, the settings are perfect :)


the easiest way would be to mix the audio together using a virtual source and then pipe it into obs. That is how i run it and it gives me the ability to do all sorts of things to my audio.

Little old-school tutorial my friend made that might help mashing those audio channels together.

i will try this the next days :)

Share this post


Link to post
Share on other sites
  • 0
MapleMooses    0

I hope you get things fixed, if not, PM me and I'd be more than happy to chat on TS and try my best to solve your issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×