Jump to content
Server time: 2018-07-18, 18:42 WE ARE RECRUITING

Sign in to follow this  
Scorch21

Help Please: OBS wont record DayZ Standalone.

Recommended Posts

SOLVED: TURN ANTI-ALIASING OFF

So I've been trying for hours now to figure out why OBS wont record DayZ. I've read all kinds of forum posts telling me to do this, that and the other thing to no avail. Here's all I've gotten so far. 

[video=youtube]

As you can see OBS only records audio and the cursor, leaving a black screen for everything else. Now I've tried checking the "use anti-cheat compatibility hook" thing, but the only thing that does is make its so you can see the DayZ cursor. I've also tried recording it in windowed mode but that didn't work either. If someone knows what to do, or even has it working somehow, please explain to me what's going on or post a screenshot of your settings. I'm all out of ideas. Thanks.

Share this post


Link to post

/Moved to troubleshooting

Share this post


Link to post

Share this post


Link to post

OBS only records when you are tabbed in, at least for me. You can try checking out your gamma settings or perhaps your recording settings. A screenshot of your OBS recording page would be nice as well.

Share this post


Link to post

Thanks! I've skimmed through those threads so far. The first one is a basic setup guide from October 2015. It seems to be outdated, if not then it has to be a problem with my PC. Like I said I've already tried windowed mode which is also what was suggested in the second link. What I'm trying to achieve here is recording DayZ in fullscreen using the "Game Capture" scene option, not the "Window Capture" or "Display Capture" options. If someone has a currently working setup using the "Game Capture" option, that's what I'm looking for.

Edit: Here is a link to my settings and scene options. https://gyazo.com/4056ab74eb6d260099d2aa256ca92184 just so you know this was taken in OBS studio, but the problem still persists in OBS classic as well.

Edit #2: These settings work perfectly in other games so the problem has to be either DayZ or Battleye.

Edit #7: I Just tried ArmA 3 with Battleye enabled and it worked fine. Has to be a DayZ thing.

Share this post


Link to post

Okay I concede, there's no way this will work with the current version of DayZ. All I can do now is record in windowed mode (bleh). If anyone wants to know how to do that, its pretty easy there's plenty of guides (pm me if you need help). Anyway the mods can go ahead and close this thread. If anyone DOES find a way to achieve what I'm looking for go ahead and pm me.  Otherwise, peace out.

Share this post


Link to post

Make sure you have the anti-cheat compatibility mode checked, a lot of people forget about this.

Share this post


Link to post

I got my OBS working with Dayz .60

I'll send you a PM with steps to follow. :)

Share this post


Link to post

No way! It's working! Thanks man! So for everyone else out there, the problem was Anti-Aliasing, just turn it off and you should be good. MapleMooses did say to run OBS as administrator as well but that didn't seem to change anything for me. Anyway, thanks a lot for the help. If anyone else needs help just PM me.

Share this post


Link to post

Glad I could help you get it fixed :)

Share this post


Link to post

May as well bump this. Since .60 hit, I've been having the same issues as OP.

Now, I've had Anti-Aliasing disabled since .57 and I run OBS as admin. As such, not sure what the issue is currently.

Anti-cheat hooking is enabled, to note.

Example of .60:

[video=youtube]

Example of .59:

[video=youtube]

Example of ARMA 3:

[video=youtube]

Share this post


Link to post

May as well bump this. Since .60 hit, I've been having the same issues as OP.

Now, I've had Anti-Aliasing disabled since .57 and I run OBS as admin. As such, not sure what the issue is currently.

Anti-cheat hooking is enabled, to note.

-snip-

I would suggest using OBS Studio. That fixed lots of issues for me.

Fixes I sent to Scorch:

-Run it as Admin.

-Update to the newest version.

-Check the Anti-cheat compatibility.

-Disable Anti-aliasing in game - then run as Game Capture on OBS.

-Use OBS Studio

Share this post


Link to post

May as well bump this. Since .60 hit, I've been having the same issues as OP.

Now, I've had Anti-Aliasing disabled since .57 and I run OBS as admin. As such, not sure what the issue is currently.

Anti-cheat hooking is enabled, to note.

-snip-

I would suggest using OBS Studio. That fixed lots of issues for me.

Fixes I sent to Scorch:

-Run it as Admin.

-Update to the newest version.

-Check the Anti-cheat compatibility.

-Disable Anti-aliasing in game - then run as Game Capture on OBS.

-Use OBS Studio

Still the same issue.

Share this post


Link to post

May as well bump this. Since .60 hit, I've been having the same issues as OP.

Now, I've had Anti-Aliasing disabled since .57 and I run OBS as admin. As such, not sure what the issue is currently.

Anti-cheat hooking is enabled, to note.

-snip-

I would suggest using OBS Studio. That fixed lots of issues for me.

Fixes I sent to Scorch:

-Run it as Admin.

-Update to the newest version.

-Check the Anti-cheat compatibility.

-Disable Anti-aliasing in game - then run as Game Capture on OBS.

-Use OBS Studio

Still the same issue.

Using OBS Studio?

Share this post


Link to post

I would suggest using OBS Studio. That fixed lots of issues for me.

Fixes I sent to Scorch:

-Run it as Admin.

-Update to the newest version.

-Check the Anti-cheat compatibility.

-Disable Anti-aliasing in game - then run as Game Capture on OBS.

-Use OBS Studio

Still the same issue.

Using OBS Studio?

Yep.

Does file type matter much? I've been using flv since I first got OBS.

Share this post


Link to post

Still the same issue.

Using OBS Studio?

Yep.

Does file type matter much? I've been using flv since I first got OBS.

It shouldn't matter. No - but you can always try .mp4

Share this post


Link to post

Using OBS Studio?

Yep.

Does file type matter much? I've been using flv since I first got OBS.

It shouldn't matter. No - but you can always try .mp4

Didn't help either way. OTL

Share this post


Link to post

Try recording in windowed mode (can change this in game or CFG file "Windowed=1")

Share this post


Link to post

Try recording in windowed mode (can change this in game or CFG file "Windowed=1")

Still didn't record the video. :(

Share this post


Link to post

Try recording in windowed mode (can change this in game or CFG file "Windowed=1")

Still didn't record the video. :(

Really.. that's very strange. 

Make sure you have no other recording software open when trying to record. (ie; shadowplay - close any of the other programs in task manager to make sure). 

Do you have a laptop or desktop?

Share this post


Link to post

Try recording in windowed mode (can change this in game or CFG file "Windowed=1")

Still didn't record the video. :(

Really.. that's very strange. 

Make sure you have no other recording software open when trying to record. (ie; shadowplay - close any of the other programs in task manager to make sure). 

Do you have a laptop or desktop?

Desktop. And only recording software I have is OBS.

Share this post


Link to post

Still didn't record the video. :(

Really.. that's very strange. 

Make sure you have no other recording software open when trying to record. (ie; shadowplay - close any of the other programs in task manager to make sure). 

Do you have a laptop or desktop?

Desktop. And only recording software I have is OBS.

Which encoder do you have selected? x264?

Share this post


Link to post

Really.. that's very strange. 

Make sure you have no other recording software open when trying to record. (ie; shadowplay - close any of the other programs in task manager to make sure). 

Do you have a laptop or desktop?

Desktop. And only recording software I have is OBS.

Which encoder do you have selected? x264?

Yep.

http://s197.photobucket.com/user/DeReaper/media/OBS1_zpsdtia0so5.png.html

http://s197.photobucket.com/user/DeReaper/media/OBS1_zpsdtia0so5.png.html

Share this post


Link to post

Can you post screen shots of your OBS settings?

Also quickly, are all of your drivers/windows up to date?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×