Jump to content
Server time: 2017-10-19, 03:30
Safe Zone: OPEN

  • 0
Sign in to follow this  
FisherMan

DayZ Standalone black screen while streaming

Question

FisherMan    0

Hello everyone! I understand this is more of a PC-program-game issue and not exactly related to this community, but I was advised to make a topic and see if anyone can figure out my problem.

To put it simply, every other game I stream is absolutely fine. Without any hitches. Although, the case isn't the same for DayZ Standalone. When I go live, I can see my mouse cursor perfectly fine, but no image. It remains dark/black for the whole time.

What I have tried so far:

- Switched from OBS Classic to OBS Studio (did not solve)

- Made sure I have anti-cheat compatibility hook turned on (did not solve)

  Image

- Verified game cache (did not solve)

- Checked my game settings (did not solve)

My video card is Gigabyte 7950 AMD if it matters.

Huge thanks to whoever tries to help me out!

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0
Oliv    1879

I had this same issue the other day. under video, I think default it is set for bi-linear (fastest)? I had to set mine to lancosz. I don't have OBS in front of me, but memory tells me that's where it is.

Share this post


Link to post
Share on other sites
  • 0
ChilliVanilli    65

same problem here, i tried to downgrade obs, but it also not works, use windowed mod for the game and obs

Share this post


Link to post
Share on other sites
  • 0
Oliv    1879

Fisherman, what encoding are you using? Are you getting audio on your stream?

Share this post


Link to post
Share on other sites
  • 0
FisherMan    0

The encoding I use for video is x264 and yes, I get audio on the stream.

Share this post


Link to post
Share on other sites
  • 0
Oliv    1879

hmmm, sounds very much like the same issue I had, but changing the video filter from Bi-linear to Lancos fixed mine. I'm currently using OBS Classic myself.

When you preview your stream, do you get your game displaying?

Share this post


Link to post
Share on other sites
  • 0
JDoberman    52

The current Game Capture on all OBS versions does not work with .60 AT ALL.

You either need to use -

1. Monitor Capture

2. Some other program.

Share this post


Link to post
Share on other sites
  • 0
Oliv    1879

The current Game Capture on all OBS versions does not work with .60 AT ALL.

You either need to use -

1. Monitor Capture

2. Some other program.

I do have it working on mine, but I use NVENC due to having an Nvidia card. Perhaps it makes a difference.

OP, try the monitor capture as suggested and see if that works. Just be careful if you alt-tab to not have sensitive information up on that monitor.

Share this post


Link to post
Share on other sites
  • 0
JDoberman    52

The current Game Capture on all OBS versions does not work with .60 AT ALL.

You either need to use -

1. Monitor Capture

2. Some other program.

I do have it working on mine, but I use NVENC due to having an Nvidia card. Perhaps it makes a difference.

OP, try the monitor capture as suggested and see if that works. Just be careful if you alt-tab to not have sensitive information up on that monitor.

Ah, yes. NVENC could work.

Share this post


Link to post
Share on other sites
  • 0
FisherMan    0

Oliv, it doesn't capture image on preview either. Will try monitor capture with OBS Studio and see if that works.

P.S: Window Capture Mode doesn't show image either. Only works when I try to Alt+Tab

P.S 2: Somehow I managed to hack it (lol). What I did was to make sure on sources it was Window Capture Mode. After that under Window Match Priority I removed the Capture Cursor option and ticked on Multi-Adapter Compatibility. On Downscale filter I use Bilinear. Still, I need to do more testing in order to confirm this as a working solution 100%.

Share this post


Link to post
Share on other sites
  • 0
Hagger    117

Good to know that you manage to get it working.

Might be a bit dumb question, but have you also tried setting your game into borderless window? You can do it by pressing Alt + Enter at the same time. Don't hold down alt and then press enter, they have to be pressed down at the same time.

Share this post


Link to post
Share on other sites
  • 0
FisherMan    0

Will test it out. Thank you!


Alright guys, I think I found the problem. If you have antialiasing on, switch it to disabled. That fixed the problem for me. Hope this information helps anyone else who may be experiencing the same problem!

Share this post


Link to post
Share on other sites
  • 0
Oliv    1879

Happy to hear you got this solved, I never thought that might have been the issue. Thanks for finding that, I'm sure it may help others in the future.

/Marking as Solved

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×