Jump to content
Server time: 2017-08-23, 23:01

Sign in to follow this  
Josh

Multiple account connection issue fix.

Recommended Posts

Josh    37

So about a year ago there was an issue with two people that were whitelisted here.

They were on the same ip and each time they tried to play DayZ at the same time on our servers one of them would get a "connection failed" message.

We were able to get a fix from Amberhelios over at the official DayZ troubleshooting forums, i got permission from him to post it here for ease of access.

Origanal question.

My brother and I play on the DayZRP Community servers. They have two linked private shard servers that are both passworded and whitelisted. 

 

We both live together (share the same IP address), and for some reason it won't allow us to connect to the servers at the same time. It simply says "connection failed" for one of us, while the other connects without issue.

 

It only seems to be an issue with these two particular servers. We can connect to any other server at the same time without any problems. The people that we've talked to from DayZRP have suggested that maybe it is an issue with DayZ in general, rather than an issue on their end.

 

The servers are called:

 

DayZRP.com - S1 EU - Role Play - www.dayzrp.com

DayZRP.com - S2 US - Role Play - www.dayzrp.com

 

Any feedback would be appreciated. Thanks!

Amberhelios's fix for the issue.

This problem is caused by an oldish home router with flaky NAT support. The solution was to force one of the clients to use a non-standard port.

In steam, right click on the game and go to "properties."

On the "General" tab, click the button to "set launch options."

On the end of the launch options, add a space followed by "-port=52302" (with no quotes).

Set every client to use a different port.

By default the game is set to use port 2302. The game also uses the ports 2 and 3 numbers higher than the designated port (ie. 2304 and 2305 if the designated port is 2302). So make sure the numbers you use are at separated by at least 4. It is safest to use ports over 49151. I would suggest using 52302, 52312, 52322, 52332, 52342 etc. One client can keep using the default.

If the above solution does not work, you may also need to do one or more of the following (try in the order given):

Enable UPnP on your router.

Enable port forwarding on your router, and forward the chosen port for each computer to that computers IP.

Restart your router

Update your router firmware (moderately tricky)

Get a new router (moderately expensive)

If you are indeed having this issue this will fix it, i have had probably 10 people use this to fix the issue.

Hope it helps.

-Josh

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×