Jump to content
Server time: 2017-10-21, 14:06
Safe Zone: CLOSED

  • 0
Sign in to follow this  
aworldofsound

Input Latency (Clicking, Key Stokes)

Question

My issue with DayZ started a few days ago:

Whenever I input any kind of "command" while running DayZ, I get ridiculous amounts of latency. I use the term command pretty loosely because it's almost as if ANY input freezes things up. For example, when on the main menu, I experience a 2-3 second delay from me clicking a tab to the game responding. This applies to just about everything GUI based; clicking "ok"s, clicking settings, scrolling down a menu, etc. This same delay also seems to apply to IG commands, as when I finally log on to a server, tapping "W" to walk forward causes a stutter. The longer I hold down W, the longer the freeze lasts for. For example, if I quickly tap W,A,S,D, after a 1 second stutter my character appears or warps to the appropriate distance. If I hold down a key for, say, 3 seconds, the game literally freezes for around 10-15 seconds until I finally "appear" in the direction I would have arrived at normally for holding down a directional key. Strangely enough, these freezes seem to only come about when press a keyboard key, or click my mouse, but moving my cursor around doesn't cause any issues. This applies both to navigating menus as well as looking around in game (when I first load in a server, I can use the mouse to move my view around without so much as a hiccup, but the second I try to walk or even hold down Alt to freelook, the freezing happens). 

I'm really at a loss, I've never encountered this issue before, and today I've run several different games, most of which pulling more CPU and GPU resources than DayZ, and they are running perfectly fine. 

Things I've tried so far:

  • Verifying game cache integrity of DayZ via Steam
  • Completely uninstalling and re-installing DayZ
  • Various edits to my DayZ config; the issue remains across the entire display spectrum, from the lowest settings on 800 x 600 to the highest on 1080p

I've searched online for solutions using keywords like "DayZ input latency" or "DayZ keyboard lag" but I keep finding solutions pertaining to generic performance tweaks for FPS milking. The closest thing I found were a few threads talking about mouse lag. Even though my mouse seemed to be the only thing NOT stuttering for me, I gave it a shot anyways but it was just more of the same DayZ.config editing. 

The game is essentially unplayable in this state; please help! :(

P.S. Here are some system specs:

XtEinCV.pngmEtml1D.png


Found this; seems to be someone with the exact same issue

http://steamcommunity.com/app/221100/discussions/0/558748653856440531/

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0
Voodoo    488

Im using Nvidia but is there a way of installing updates to The graphics your using? (The drivers)

Also have you checked if there is anything running in the background that could be using up performance?

After reading the link you added have you tried installing experimental testing a server then uninstalling it to see is it runs better?

Share this post


Link to post
Share on other sites
  • 0
Jackfish    0

I have the freezing problem to.

And I got a.. lets say very good pc.

So I didn't build the PC myself, I called the service for help. In my case it is the harddrive and im going to send that back for a new one.

What im trying to say: Could it be your hardware? you got hardware tests to see if your hardware is ok.

Share this post


Link to post
Share on other sites
  • 0

Im using Nvidia but is there a way of installing updates to The graphics your using? (The drivers)

Also have you checked if there is anything running in the background that could be using up performance?

After reading the link you added have you tried installing experimental testing a server then uninstalling it to see is it runs better?

I'm using an AMD 6870 and I've already updated my video drivers and it didn't change anything. Before my last uninstall, I also tried running DayZ in the experimental mode and the issue remained. Thank you for the suggestions!


I have the freezing problem to.

And I got a.. lets say very good pc.

So I didn't build the PC myself, I called the service for help. In my case it is the harddrive and im going to send that back for a new one.

What im trying to say: Could it be your hardware? you got hardware tests to see if your hardware is ok.

I've been considering this as an option, and while I figure it's possible, it seems odd how my hardware (assuming that's the issue) is entirely selective about what has this issue. Like I said, other, more CPU and GPU intensive stuff run fine, and I haven't had issues with other programs either. Seeing as removing my harddrive is pretty drastic, I'd save those measures as a last resort. Thank you for the input!


Sort of a pseudo-update here, but last night after getting some tips from the help desk (thanks Whip), I uninstalled DayZ again and afterwards ran CCleaner to fix registry errors, clean up old files, even wipe clean my empty space which took several hours so I left it running over night. Before I re-install, it was recommended that I go ahead and defragment my disk as I haven't done that in a few years and I'd hate to re-install DayZ only to find the cleaner didn't help, at which point I'd have wasted several hours re-installing, un-installing, re-wiping, then defragmenting before reinstalling once more. Seeing as I have ~2TB of disk space (~900GB used) and I haven't done this in a while, I'm expecting this to take a good chunk of the day but I'll post updates as soon as I can as well as track this thread on my phone. 

Fingers crossed! :)

Share this post


Link to post
Share on other sites
  • 0
Voodoo    488

Let us know if you have managed to fix the probslem with what you have done ;)

Share this post


Link to post
Share on other sites
  • 0

So...bad news. Despite all my efforts, the issue remains. Short of contacting Bohemia and seeing if I can get some tech support, I really don't know what else I can do at this point. I did discover something I didn't notice before, however:

FNksWrR.png

I'm not too tech-savvy so this might not be out of the ordinary, but it seems like 1 of my 4 cores is working a lot harder than the other 3. Is that normal? I was under the impression cores were supposed to divide the workload.

Share this post


Link to post
Share on other sites
  • 0
Shark    0

That's unfortunately because DayZ isn't optimized for multicore CPUs, as it really only utilizes one core of any processor.

Share this post


Link to post
Share on other sites
  • 0
Voodoo    488

Im no computer wiz and all i can really do is keep looking around for similar issues.

I think the best bet would be see what bohemia come up with and if anyone in the community may have a solution.

Ill keep checking around when i can, keep us updated

Share this post


Link to post
Share on other sites
  • 0

Im no computer wiz and all i can really do is keep looking around for similar issues.

I think the best bet would be see what bohemia come up with and if anyone in the community may have a solution.

Ill keep checking around when i can, keep us updated

Sure thing. Thank you guys so much for all the help so far; this process is frustrating but it's good to know I'm not going it alone. Last night I sent in a support form to Bohemia as well as posted on their official feedback forums. I haven't gotten any word yet but I'll post here when I do.

Share this post


Link to post
Share on other sites
  • 0

Still no work back from BI support, or any news on the DayZ Feedback forums, but I did just copy my original post into a thread I found on the official DayZ troubleshooting forums; we'll see what happens. Apparently this person, and a handful others in the thread have the same issue as me, but are doing a piss-poor job of elaborating...

http://forums.dayzgame.com/index.php?/topic/226406-as-soon-as-i-step-it-freezes/?p=2292448

Share this post


Link to post
Share on other sites
  • 0
Voodoo    488

Yea i havent found much other than what has already been brought up.

Hopefully you will hear back from BI soon with a fix but also possibility of stable update next week may fix the problem.

Share this post


Link to post
Share on other sites
  • 0
Jackfish    0

Im going to send my Harddrive away this Monday because I had the problem today.

I still think u should send the harddrive back or buy a new one. I know its hard but I think that will fix the problem ;)

Share this post


Link to post
Share on other sites
  • 0
Josh    37

World of sound what are your internet speeds?

You could possibly try defragging your hard drive before sending it out like jack fish suggested.

Also could you try monitoring your ram/cpu while replicating the issue?

I see in the above screen shots you are only on the loading screen.

There's a bunch of things we can try let us know if anything helps.

^___^

Goodluck

Josh

Share this post


Link to post
Share on other sites
  • 0

So, I finally received word back from the support team at BI, and while I was skeptical at first about their suggestion, turns out they were right.

MiI0fDX.png

Cleared up some malware and for whatever reason, it fixed DayZ for me.  Here are the links in clickable format in case anyone else gets this issue.

http://www.iobit.com/en/malware-fighter.php

https://www.malwarebytes.org/

Share this post


Link to post
Share on other sites
  • 0
Whip    0

Im Glad We figure this out! Even if it took a while!

Please feel free to post again if any more issues come up!

-Whip

/Solved

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×