Jump to content
Server time: 2017-10-19, 00:17
Safe Zone: CLOSED

  • 0
Sign in to follow this  
Teas

ARMA 3 update question

Question

Teas    1

I know, I know it's not DayZ related but I'm at my wits end and hope you fine gentlemen with your giant techy brains can help me.

I tried to play online Arma 3 this evening and low and behold none of the servers will let me connect.

I checked my current version of the game (1.18.124200) against the required version (1.30.124). But I cannot get STEAM to update my game.

Any STEAM savvy people willing to offer a fix or a workaround for this? I've tried many googling efforts but no help.

Cheers in advance.

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0
Masulii    25

Have you tried to verify the game? My friend had this kind of problem and I believe that it fixed it. Also, if it doesn't start to update the game, restart Steam, hopefully it starts to update.

1) Verify game integrity

2) Restart Steam (^ if doesn't begin to update)

Share this post


Link to post
Share on other sites
  • 0
Jack Kolb    0

Hmm verify the integrity of the game?

Otherwise maybe restart steam and/or your pc sometimes it seems to be that if steam needs to update and you didn't update it you can't also update games.

Share this post


Link to post
Share on other sites
  • 0
Teas    1

Verifying game files now, once that's done I'm going to restart my PC and see what happens.

Thanks for the lightning fast responses.

EDIT: Ok, validated, here goes.


Nope, not a sausage. I'm frustrated and baffled as to why it won't update.

Share this post


Link to post
Share on other sites
  • 0
Masulii    25

Have you restarted your Steam? It may trigger update

Share this post


Link to post
Share on other sites
  • 0
Teas    1

Have you restarted your Steam? It may trigger update

Yup, restarted PC and still displaying the old version when I start the game. All servers require version 1.30 or higher.

Google seems to give me nothing as Steam updates as you know are automatic.

Pissing me off now.

Share this post


Link to post
Share on other sites
  • 0
Masulii    25

Hmm....try changing from Stable to Dev build and back?

Share this post


Link to post
Share on other sites
  • 0
Jm Von Cat    154

Right click on the ARMA III icon, then select the "Launcher" option, this will open a small window, in the bottom of which it will tell you if your game is up to date.

Also, is it one specific game type or mode? or all of them?

Share this post


Link to post
Share on other sites
  • 0
Diggy    0

Verifying game files now, once that's done I'm going to restart my PC and see what happens.

Thanks for the lightning fast responses.

EDIT: Ok, validated, here goes.


Nope, not a sausage. I'm frustrated and baffled as to why it won't update.

When you try to update it does it just close the update and highlight the game in blue saying "Update queued" or something like that?

If that is the case, I had a similar issue with my Arma 2 recently. I was told to check my firewall settings, and after disabling the firewall, it worked and updated for me. It's worth a shot looking into this.

Share this post


Link to post
Share on other sites
  • 0
Guest Astycc   
Guest Astycc

If it is stuck at 0% on steam just re-install it, that's what I had to do

Share this post


Link to post
Share on other sites
  • 0
Teas    1

Hmm....try changing from Stable to Dev build and back?

Tried that multiple times, dev mode crashes on startup. But when I switch back to stable I have the same issue.

Right click on the ARMA III icon, then select the "Launcher" option, this will open a small window, in the bottom of which it will tell you if your game is up to date.

Also, is it one specific game type or mode? or all of them?

I checked that and it says it's "the game is up to date". However, when I get to the main menu of the game, in the bottom right hand corner it displays the current version as 1.18.124200.

EDIT: Also it's for all game modes. It displays the red cross icon and in the bottom left window says in red, "1.30 required".

As for updating queue, it doesn't. It seems to think it's at the correct version.

Hmmmm.

Share this post


Link to post
Share on other sites
  • 0
Masulii    25

-snip-

Okay, this may sound stupid but do you have any mod enabled? Like Battle Royale?

Try disabling that, then verify game integrity

If I remember correctly, my friend had Battle Royale enabled and that kinda blocked the game for updating, due to the "game version" being correct with that mod he had.

Share this post


Link to post
Share on other sites
  • 0
Teas    1

-snip-

Okay, this may sound stupid but do you have any mod enabled? Like Battle Royale?

Try disabling that, then verify game integrity

If I remember correctly, my friend had Battle Royale enabled and that kinda blocked the game for updating, due to the "game version" being correct with that mod he had.

No mods except Zeus, but I'm unsure how to disable it as it doesn't give me any options in game, under addons.

Share this post


Link to post
Share on other sites
  • 0
Burgz    6

No mods except Zeus, but I'm unsure how to disable it as it doesn't give me any options in game, under addons.

Urm, if it's like Arma 2 folders then you can go in there and remove the '@' sign from the title of the Zeus folder. This should disable it I believe.

Share this post


Link to post
Share on other sites
  • 0
Masulii    25

No mods except Zeus, but I'm unsure how to disable it as it doesn't give me any options in game, under addons.

Hmm...Zeus shouldn't be any trouble. You can be extreme and delete something from the game files and then verify the integrity because the game notices that there is something missing, it will re-download it. That can also maybe trigger an update.

But I am off to sleep, hope that I have helped in some way (atleast eliminating the wrong options xD), hope that you get it working

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Go in to your Arma 3 files (Where you put in mods directly) and just delete the entire Arma 3 folder. Then reinstall, this has helped me for other games, it should get your game updated.

Share this post


Link to post
Share on other sites
  • 0
Teas    1

Righto, just deleated EVERYTHING. Reinstalling now, hope this does the trick.

Thanks for all the help by the way everyone. Fingers crossed, this is my last option of the evening. So if it doesn't work I'll pick up again tomorrow.


Go in to your Arma 3 files (Where you put in mods directly) and just delete the entire Arma 3 folder. Then reinstall, this has helped me for other games, it should get your game updated.

That did the trick. Cheers mate.

Mark as solved please.

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Solving.

Solution: Go in to your Arma 3 files (Where you put in mods directly) and just delete the entire Arma 3 folder. Then reinstall, this has helped me for other games, it should get your game updated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×