Jump to content

Server time (UTC): 2021-09-23 23:36

DayzRP won't open correctly


Recommended Posts

Hello, I have resently an big bug that I cant fix myself.

this is whats happening: I start DayzRP true my launcher, it gives me an warning saying: Addon 'CA_CommunityConfigurationProject_E' requires addon 'CA_AIR_E_MQ9PredatorB.

I dont know really what that means so I press OK.

then it start arma 2 not operation arrowhead, and then it says bad version server rejected.

I dont know how to fix it because I have re-installed everything. I even tried to go on Dayz commander and try to switch the path to the DayzRP map whitout succses.

Link to comment
  • Server Manager

You're not launching the game with beta executable.

Link to comment
  • MVP

What happens when you launch ARMA 2 OA through steam?

Link to comment
  • MVP

What happens when you launch ARMA 2 OA through steam?

It launches but it launches the DayzRP version, its the same if you launch arma 2 OA in the DayzRP launcher.

...

So it opens correctly? Where is the issue then?

Link to comment

What happens when you launch ARMA 2 OA through steam?

It launches but it launches the DayzRP version, its the same if you launch arma 2 OA in the DayzRP launcher.

...

So it opens correctly? Where is the issue then?

No you cant play the game true the menu you just cant see the servers true normal arma 2 OA.

so to make it clear: I open the launcher I hit S2 and then I get the error I hit OK and it tries to open it true arma 2 for some reason.

then it says in arma 2: wrong version server rejected. so I am in arma 2 now and I quite the game.

Link to comment
  • MVP

On the main menu bottom right corner

What version does it give you?

Link to comment
  • Legend

Moved to Troubleshooting.

It says: 1.6.3.125548

You need to downgrade your Arma 2 OA to 1.62.

To do this, go to Steam -> right click Arma 2 OA -> Preferences -> Betas -> 1.62 - older version of game.

Link to comment

Moved to Troubleshooting.

It says: 1.6.3.125548

You need to downgrade your Arma 2 OA to 1.62.

To do this, go to Steam -> right click Arma 2 OA -> Preferences -> Betas -> 1.62 - older version of game.

Thanks for the tip but unfortunately it didn't work.

I get the same problem even on 1.6.2

Link to comment
  • Legend

Perhaps try if any of these solutions in this thread would help you.

Link to comment

Perhaps try if any of these solutions in this thread would help you.

well I hope there would be an solution to this problem.

and if there is not an solution to this problem I hope it would be fixed in the new patch that comes out soon.

Link to comment
Guest magw33d

You need to install OA Beta patch 103718 since you are running the wrong beta version.

Before you install the patch however, you will need to delete the Beta folder in Common\Arma 2 Operation Arrowhead\Expansions.

The Arma 2 website is down right now, but don't worry, I have found a mirror for you on a dodgy looking website.

http://www.playerattack.co.uk/file/40685/ARMA-2-Operation-Arrowhead-Patch-1.63-BETA-Build-103718/

I've gone through the effort of testing the file for you to make sure it is legit, so go ahead and download :)

Link to comment

You need to install OA Beta patch 103718 since you are running the wrong beta version.

Before you install the patch however, you will need to delete the Beta folder in Common\Arma 2 Operation Arrowhead\Expansions.

The Arma 2 website is down right now, but don't worry, I have found a mirror for you on a dodgy looking website.

http://www.playerattack.co.uk/file/40685/ARMA-2-Operation-Arrowhead-Patch-1.63-BETA-Build-103718/

I've gone through the effort of testing the file for you to make sure it is legit, so go ahead and download :)

Wauw thanks a lot for the effort you put in. but unfortunately it doesn't work eather I think we need to look at the warning it gives me and a bit more arround normal arma 2 because the game wants to start in arma 2.

the warning I got is: Addon'CA_CommunityConfigurationProject_E' requiresaddon'CA_AIR_E_MQ9PredatorB

Link to comment
Guest magw33d

Pop into the Common\Arma 2 Operation Arrowhead\Expansions\beta folder and make a shortcut to arma2oa.exe.

Right click that, hit properties, and add this to the end of the target field:

-mod=dayzrp

Ticket the box for 'run in administrator mode' under the compatibility tab.

Use this to run the mod instead of the launcher, it seems it isn't working correctly for you.

If the errors persist, I advise you to use the launcher to verify your DayZRP data, or download the manual install files.

Link to comment

Pop into the Common\Arma 2 Operation Arrowhead\Expansions\beta folder and make a shortcut to arma2oa.exe.

Right click that, hit properties, and add this to the end of the target field:

-mod=dayzrp

Ticket the box for 'run in administrator mode' under the compatibility tab.

Use this to run the mod instead of the launcher, it seems it isn't working correctly for you.

If the errors persist, I advise you to use the launcher to verify your DayZRP data, or download the manual install files.

Well Thanks for the help but the shortcut target field can not find the correct path, so for some reason that doesn't work eather. and I have tried to re-instal the files manual but that doesn't work to. mabey we need to look at the warning because I have found some codes in the D:\steam\SteamApps\common\Arma 2 Operation Arrowhead\Expansion\beta\expansion\addons that looks like it but I dont know if I have to copy and paste those somewhere or not?

whatever the case I dont think it is something what arma 2 OA

Link to comment
Guest magw33d

Please paste the shortcut target so I can see what you have put in there.

There should be three files in that folder.

7321dfe06a.png

The error Addon'CA_CommunityConfigurationProject_E' requiresaddon'CA_AIR_E_MQ9PredatorB implies that there is a file corruption, start Steam in admin mode and validate the files for both Arma 2 and Operation Arrowhead. I'd also turn off automatic updates on them to avoid it downloading the latest version when it validates.

Link to comment

I put this in the shortcut target: "D:\steam\SteamApps\common\Arma 2 Operation Arrowhead\Expansion\beta\arma2oa.exe-mod=dayzrp''

and I have validated the games in steam as administrater. but I can also do restart my computter to a point when I did not have this problem like 2 week ago for example, but I dont really like to do that but I can do that as an last resort.


Please paste the shortcut target so I can see what you have put in there.

There should be three files in that folder.

7321dfe06a.png

The error Addon'CA_CommunityConfigurationProject_E' requiresaddon'CA_AIR_E_MQ9PredatorB implies that there is a file corruption, start Steam in admin mode and validate the files for both Arma 2 and Operation Arrowhead. I'd also turn off automatic updates on them to avoid it downloading the latest version when it validates.

^

|

|

Link to comment
Guest magw33d

Change your target to:

"D:\steam\SteamApps\common\Arma 2 Operation Arrowhead\Expansion\beta\arma2oa.exe -mod=dayzrp''

It was missing a space ^^

If you have validated the files with 1.62 and 103718 installed it should launch correctly with no errors.

Link to comment

Change your target to:

"D:\steam\SteamApps\common\Arma 2 Operation Arrowhead\Expansion\beta\arma2oa.exe -mod=dayzrp''

It was missing a space ^^

If you have validated the files with 1.62 and 103718 installed it should launch correctly with no errors.

We tried all of these things, yet he still gets the

Addon'CA_CommunityConfigurationProject_E' requiresaddon'CA_AIR_E_MQ9PredatorB Error

Link to comment

Change your target to:

"D:\steam\SteamApps\common\Arma 2 Operation Arrowhead\Expansion\beta\arma2oa.exe -mod=dayzrp''

It was missing a space ^^

If you have validated the files with 1.62 and 103718 installed it should launch correctly with no errors.

We tried all of these things, yet he still gets the

Addon'CA_CommunityConfigurationProject_E' requiresaddon'CA_AIR_E_MQ9PredatorB Error

John kinda helped me too, but with no success

Link to comment
Guest magw33d

Change your target to:

"D:\steam\SteamApps\common\Arma 2 Operation Arrowhead\Expansion\beta\arma2oa.exe -mod=dayzrp''

It was missing a space ^^

If you have validated the files with 1.62 and 103718 installed it should launch correctly with no errors.

We tried all of these things, yet he still gets the

Addon'CA_CommunityConfigurationProject_E' requiresaddon'CA_AIR_E_MQ9PredatorB Error

Did you try deleting the corrupt pbo and then validating?

Link to comment

Change your target to:

"D:\steam\SteamApps\common\Arma 2 Operation Arrowhead\Expansion\beta\arma2oa.exe -mod=dayzrp''

It was missing a space ^^

If you have validated the files with 1.62 and 103718 installed it should launch correctly with no errors.

We tried all of these things, yet he still gets the

Addon'CA_CommunityConfigurationProject_E' requiresaddon'CA_AIR_E_MQ9PredatorB Error

Did you try deleting the corrupt pbo and then validating?

yes I have tried it now but it doesn't work, and funny enough it doesn't want to replace the PBO file back where it belongs, so there is no PBO file in the beta map. only 2 BISIGN files.

and it still tries to run it in arma 2.


but can't the dev give me the 'CA_AIR_E_MQ9PredatorB addon that is required?

Link to comment
  • MVP

We tried all of these things, yet he still gets the

Addon'CA_CommunityConfigurationProject_E' requiresaddon'CA_AIR_E_MQ9PredatorB Error

Did you try deleting the corrupt pbo and then validating?

yes I have tried it now but it doesn't work, and funny enough it doesn't want to replace the PBO file back where it belongs, so there is no PBO file in the beta map. only 2 BISIGN files.

and it still tries to run it in arma 2.


but can't the dev give me the 'CA_AIR_E_MQ9PredatorB addon that is required?

No, that file is a part of ARMA 2 not DayZRP.

To be honest it sound like your install is corrupted to hell, try wiping it from your PC and then installing a fresh copy of ARMA

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...