Jump to content
Server time: 2017-08-21, 01:02

  • 0
Sign in to follow this  
Dieskrad

"Bad version, server rejected connection", but everything seems fine?

Question

Dieskrad    0

[attachment=1131][attachment=1129][attachment=1130]Insert me realizing I'm whitelisted

insert lots of hype

insert error, proceed to insert rage.

So yeah, I downloaded the DayzRP mod (torrent) I installed that bad boy, downloaded the DayzRP launcher and got the error mentioned in the title, I do have the beta patch updated, I installed it through Steam and patched it there too. I tried using the server's launcher and also tried to do it manually (or well, with Steam). As far as I know (which isn't much to be honest), everything's alright with my game, but come to think about it, I get this same error in every server that doesn't use BattleEye, so maybe that's something? I dunno. Help would be appreciated.

I have no idea how attachments work, I'm a forum n00b, I might just upload the screenshots of the issues to some site and then link it here if the images don't show up.

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0
Guest   
Guest

Download DayZ commander. Go to Install/update and update your ArmA 2.

Share this post


Link to post
Share on other sites
  • 0
Dieskrad    0

Download DayZ commander. Go to Install/update and update your ArmA 2.

Uh...

Well I did that and now I can't run the game at all, Steam says there's a missing executable, and Dayz Commander says this:

ARMA 2: NOT FOUND (Out of date), that's on the install/update thingy.

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Download DayZ commander. Go to Install/update and update your ArmA 2.

Uh...

Well I did that and now I can't run the game at all, Steam says there's a missing executable, and Dayz Commander says this:

ARMA 2: NOT FOUND (Out of date), that's on the install/update thingy.

Have uou changed your directory? If so set the paths on both the DayZRP launcher and Dayz commander.

Share this post


Link to post
Share on other sites
  • 0
Dieskrad    0

Download DayZ commander. Go to Install/update and update your ArmA 2.

Uh...

Well I did that and now I can't run the game at all, Steam says there's a missing executable, and Dayz Commander says this:

ARMA 2: NOT FOUND (Out of date), that's on the install/update thingy.

Have uou changed your directory? If so set the paths on both the DayZRP launcher and Dayz commander.

I don't think I have, but in any case, it seems that the issue is a Steam thing.

I'm gonna reboot my PC as I'm kinda going with this just to check if it works https://support.steampowered.com/kb_article.php?ref=8676-EFLX-7453&l=english.

After that, I'll check if it works and go to sleep, I'll tell you guys what's up tomorrow morning hopefully.

Share this post


Link to post
Share on other sites
  • 0
Dieskrad    0

From here; http://www.dayzrp.com/t-technical-troubleshooting-faq-read-before-posting

Solution:

This means that you don't have the Beta patch installed or the beta patch that the server requires you have in order to connect.

- Downloading beta patch 103718 here.

- Proceed to use the following here.

I do have the beta patch updated [...] I tried using the server's launcher and also tried to do it manually (or well, with Steam)

Even if you assume that I don't have it even though I say I do, I wouldn't be able to join any server at all, but my only issue was with servers that don't require BattleEye, basically, "updating" Arma 2 through DayZ Commander screwed me over.

(The Steam thing did not work).

Share this post


Link to post
Share on other sites
  • 0
Guest JMS   
Guest JMS

From here; http://www.dayzrp.com/t-technical-troubleshooting-faq-read-before-posting

Solution:

This means that you don't have the Beta patch installed or the beta patch that the server requires you have in order to connect.

- Downloading beta patch 103718 here.

- Proceed to use the following here.

I do have the beta patch updated [...] I tried using the server's launcher and also tried to do it manually (or well, with Steam)

Even if you assume that I don't have it even though I say I do, I wouldn't be able to join any server at all, but my only issue was with servers that don't require BattleEye, basically, "updating" Arma 2 through DayZ Commander screwed me over.

(The Steam thing did not work).

Can't you install DayZ commander takes like 2 mins

Share this post


Link to post
Share on other sites
  • 0
Dieskrad    0

I do have the beta patch updated [...] I tried using the server's launcher and also tried to do it manually (or well, with Steam)

Even if you assume that I don't have it even though I say I do, I wouldn't be able to join any server at all, but my only issue was with servers that don't require BattleEye, basically, "updating" Arma 2 through DayZ Commander screwed me over.

(The Steam thing did not work).

Can't you install DayZ commander takes like 2 mins

I didn't realize I wasn't being clear with the "updating Arma 2 through DayZ Commander screwed me over", but yeah, what sorta broke my game was DayZ Commander.

Share this post


Link to post
Share on other sites
  • 0
Guest JMS   
Guest JMS

Even if you assume that I don't have it even though I say I do, I wouldn't be able to join any server at all, but my only issue was with servers that don't require BattleEye, basically, "updating" Arma 2 through DayZ Commander screwed me over.

(The Steam thing did not work).

Can't you install DayZ commander takes like 2 mins

I didn't realize I wasn't being clear with the "updating Arma 2 through DayZ Commander screwed me over", but yeah, what sorta broke my game was DayZ Commander.

I'm extremely confused however if you have the time go into the teamspeak help desk on the DayZRP teamspeak and explain it to Mush or someone else through voice I will be there I'll see If I can help because at the moment I'm confused with this :P

Share this post


Link to post
Share on other sites
  • 0
SweetJoe    281

You are using arma client 1.63.116523 1.3.4.? Is that what it says in the lower right corner of the first screenshot? You need to be on 103718

we play on a different patch version than most dayz servers. You need to downgrade to the version I just listed. Easiest way to do this is the update list on commander. There is a scroll menu where you can point and click the appropriate version.

Share this post


Link to post
Share on other sites
  • 0
Dieskrad    0

You are using arma client 1.63.116523 1.3.4.? Is that what it says in the lower right corner of the first screenshot? You need to be on 103718

we play on a different patch version than most dayz servers. You need to downgrade to the version I just listed. Easiest way to do this is the update list on commander. There is a scroll menu where you can point and click the appropriate version.

I already did that, and after doing it I get a "there's a missing executable" from Steam, and I can't run the game at all, unless I don't run it with the beta patch.


It is definitely because I downgrade with Dayz Commander, I reinstalled the beta patch and everything worked just fine until I tried to go back to 103718 again, it seems that doing this makes the .exe for the beta patch disappear or something.

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

It has been a while since the OP has replied to this thread. I will solve & close it because of that.

If the OP wants this to be re-opened PM me asking me to do so.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×