Jump to content
Server time (UTC): 2021-01-21, 05:54
Sign in to follow this  
Burgz

Bad version, server rejected connection

Recommended Posts

Well, I never actually made my own thread, only hijacked someone elses.

I've tried deleting the launcher.

I've tried re-installing ARMA 2 OA.

I've tried installing the ARMA 2 update from Commander numerous amounts of times.

I've tried a system restore before the update for ARMA.

None of these have worked so far, and I really don't know what to do.

halp

Share this post


Link to post

Have you done the beta patch thingy?

If not, I can run you through the process for you.

Share this post


Link to post

I had the same problem. I updatet the normal Arma2 with the DayZCommander. Just open the install/update rooster and update the normal Arma2 at the top.

Share this post


Link to post

Have you done the beta patch thingy?

If not, I can run you through the process for you.

What one is that?

I had the same problem. I updatet the normal Arma2 with the DayZCommander. Just open the install/update rooster and update the normal Arma2 at the top.

When I do that, it just gives a load of error messages such as 'Bad CD Key' etc. It still doesn't seem to work afterwards.

Share this post


Link to post

Basically, go to your ArmA2:OA directory. So the usual,

C:\Program Files (x86)\Steam\SteamApps\common\arma 2 operation arrowhead\

Then go into expansions, either move or delete the beta folder in there. Then, go here and click: ArmA2:OA Beta Patch 103718

Once it's downloaded, open the .exe file and let it do its thing. On completion of this, launch your Arma and see if you can join RP. Hopefully it should fix the problem. If not, I will look further into it for you.

Share this post


Link to post
Solution:

This means that you don't have the Beta patch installed or the beta patch that the server requires you have in order to connect.

- Downloading the latest patch here.

- Proceed to use the following here.

Source: http://www.dayzrp.com/t-technical-troubleshooting-faq-read-before-posting

Share this post


Link to post

Basically, go to your ArmA2:OA directory. So the usual,

C:\Program Files (x86)\Steam\SteamApps\common\arma 2 operation arrowhead\

Then go into expansions, either move or delete the beta folder in there. Then, go here and click: ArmA2:OA Beta Patch 103718

Once it's downloaded, open the .exe file and let it do its thing. On completion of this, launch your Arma and see if you can join RP. Hopefully it should fix the problem. If not, I will look further into it for you.

The first thing I done was that and as you can guess, to no avail.


Solution:

This means that you don't have the Beta patch installed or the beta patch that the server requires you have in order to connect.

- Downloading the latest patch here.

- Proceed to use the following here.

Source: http://www.dayzrp.com/t-technical-troubleshooting-faq-read-before-posting

What? That's for updating the mod no?

Share this post


Link to post

Basically, go to your ArmA2:OA directory. So the usual,

C:\Program Files (x86)\Steam\SteamApps\common\arma 2 operation arrowhead\

Then go into expansions, either move or delete the beta folder in there. Then, go here and click: ArmA2:OA Beta Patch 103718

Once it's downloaded, open the .exe file and let it do its thing. On completion of this, launch your Arma and see if you can join RP. Hopefully it should fix the problem. If not, I will look further into it for you.

The first thing I done was that and as you can guess, to no avail.


Solution:

This means that you don't have the Beta patch installed or the beta patch that the server requires you have in order to connect.

- Downloading the latest patch here.

- Proceed to use the following here.

Source: http://www.dayzrp.com/t-technical-troubleshooting-faq-read-before-posting

What? That's for updating the mod no?

Burgz, what happened to you?

"Bad version, server rejected connection"

Means that your ArmA version isnt the same as the one recommended by the server.

Start ArmA OA and #dayzRp mod all the different ways you know of, when in lobby escape out to menu and look what version ArmA has started for you, right down corner. Should be 162. 103718

Please check what version ArmA is loading for you, check different start options.

From this we know what we have to do first.

For now just leave the mod part.

Share this post


Link to post

-text-

I really don't know.

It says 1.63 still/

Share this post


Link to post

-text-

I really don't know.

It says 1.63 still/

Then do as Jamesy wrote above.

Run the beta exe file as admin, just click ok when bad cd version conversation box appears.

Then restart game again and check version.

Share this post


Link to post

-text-

I really don't know.

It says 1.63 still/

Then do as Jamesy wrote above.

Run the beta exe file as admin, just click ok when bad cd version conversation box appears.

Then restart game again and check version.

I deleted the beta?

Share this post


Link to post

If you've deleted the beta, go here and download the beta patch from there. (Top of the page)

Once the file has downloaded, launch the .exe file. Click yes one everything, once it's done, launch your game and all shall be done.

Share this post


Link to post

I really don't know.

It says 1.63 still/

Then do as Jamesy wrote above.

Run the beta exe file as admin, just click ok when bad cd version conversation box appears.

Then restart game again and check version.

I deleted the beta?

Thats what you should do, or rename the beta folder, then run the beta exe file as admin and the beta folder will be created again with choosen beta version (103718) content.

Share this post


Link to post

Then do as Jamesy wrote above.

Run the beta exe file as admin, just click ok when bad cd version conversation box appears.

Then restart game again and check version.

I deleted the beta?

Thats what you should do, or rename the beta folder, then run the beta exe file as admin and the beta folder will be created again with choosen beta version (103718) content.

I ran it, but I had no option to 'run as admin'?

Share this post


Link to post

Im having the same issue-

Up to date Arma

Up to date Arma beta

Up to date DayZ RP + standard DayZ (although not enabled)

Ive verified Arma on steam too

Share this post


Link to post

I deleted the beta?

Thats what you should do, or rename the beta folder, then run the beta exe file as admin and the beta folder will be created again with choosen beta version (103718) content.

I ran it, but I had no option to 'run as admin'?

Open the the zip package, then run the ArmA2_OA_Build_103718.exe file as admin by right mouse click and use option "run as administrator".

Share this post


Link to post

9cfacdbc66.png

04ca84133b.png

6048128ee3.png

I don't get the option to run as admin, this is what happens when running it.

Share this post


Link to post

Im having the same issue-

Up to date Arma

Up to date Arma beta

Up to date DayZ RP + standard DayZ (although not enabled)

Ive verified Arma on steam too

You also getting, "Bad version, server rejected connection"?

Then first make sure your ArmA version is right.

Could be so that Steam updated your Beta when you verified.

Share this post


Link to post

When I try install the correct beta patch it says I have wrong CD key

Share this post


Link to post

9cfacdbc66.png

04ca84133b.png

6048128ee3.png

I don't get the option to run as admin, this is what happens when running it.

You are running the ArmA2_OA_Build_103718.exe file direct from the ArmA2_OA_Build_103718.zip package right ?

Share this post


Link to post

Exact same as Burgz and yes im running it as administrator, after extracting the file

Share this post


Link to post

When I try install the correct beta patch it says I have wrong CD key

When running the ArmA2_OA_Build_103718.exe you always get a bad cd key conversation box, just click ok.

Share this post


Link to post

When I try install the correct beta patch it says I have wrong CD key

When running the ArmA2_OA_Build_103718.exe you always get a bad cd key conversation box, just click ok.

It's not an exe, but an application? Thats fine yeah?

Share this post


Link to post

When I try install the correct beta patch it says I have wrong CD key

When running the ArmA2_OA_Build_103718.exe you always get a bad cd key conversation box, just click ok.

It's not an exe, but an application? Thats fine yeah?

You should run ArmA2_OA_Build_103718.exe from the the ArmA2_OA_Build_103718.zip package, nothing else.

Maybe you dont see file extensions in your file browser, you can enable that, makes things easier when comes to se different file types then.

Share this post


Link to post

Right well im still can't connect to the servers

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...