Jump to content

Server time (UTC): 2022-05-21 02:34

Bad Version, server rejected connection/missing content


Recommended Posts

I have been trying to connect to DayZRP and keep getting the error "Bad Version, Server Rejected Connection". I am only getting this error when trying to launch the game with DayZRP enabled. I have tried to launch manually, via the launcher, and via steam launch parameters; but to no avail. I am capable of launching base ArmA 2 (and OA) without any issues. I was also able to launch all of my realism mods without fault. Any kind of help would be lovely.

-Thanks in advance, Sam.

Edit: None of the below fixes have worked, or if they have they just caused another issue which is posted below.

Link to comment

Go to DayZ Commander, click on install/update, update your ArmA 2.

Fixed for my gaming rig and for my laptop.

Ugh I need to install DayZ Commander. Okay, thank you I will and tell you if that fixed the problem.


Go to DayZ Commander, click on install/update, update your ArmA 2.

Fixed for my gaming rig and for my laptop.

Well it got rid of that problem and now I have this one. I only have the addons that are enabled by the DayZRP launcher. FAoaZHf.jpg

Link to comment
  • Emerald

I know it sounds sinple but try verifying your arma in steam

Link to comment

It says common/....filename...

I checked its from the game I believe not the mod so remove these files and let steam fix your game.

Or put whole game in you trashcan(recyclebin whatever its called for you) and put it back. It worked for martin.

Link to comment
Guest magw33d

I had this problem after updating Arma 2 with steam.

To fix it, I first located the beta folder at

C:\Program Files (x86)\Steam\SteamApps\common\Arma 2 Operation Arrowhead\Expansion

I then deleted it, and downloaded the reccomended beta patch for Arma 2 that we use,

http://www.arma2.com/downloads/update/beta/ARMA2_OA_Build_103718.zip

I installed this, then loaded up Arma 2 through the beta launcher that is in the expansion folder.

If you are having problems with file inconsistencies, verify both Operation Arrowhead and Arma 2 via steam, and make sure you launch them independently one after the other to validate the game key.

Link to comment
  • Sapphire

After a quick search I found this:

Step 1: Close steam, and launch it again as Adminstrator.

Step 2: Right click on Arma 2 in your steam library, then click on Properties, after that click on the Local Files tab, the click Verify integrity of game cache. Then wait for that to finish

Step 3: Repeat Step 2 but instead of Arma 2 Verify the Arma 2: Operation Arrowhead.

Step 4: After you have gotten that done, launch Arma 2, close it, then launch AO, then close it.

You can also try this link.

Link to comment
  • Emerald

Okay, I'll mark this as solved.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...