Jump to content

Server time (UTC): 2022-05-24 22:22

Turtle Beach PX21 Problem


Recommended Posts

I realize that in all honesty people probably don't know much about my problem, but it's worth a try anyway.

Here is the volume control deck on my headset, Turtle Beach PX21s:

PX21_AMP_how_does_it_work1.jpg

You can see that there is a game control and a chat control button. However when I plug my headset into the PC, usually, the chat volume controls EVERYTHING and when I turn up the game volume, it just makes a crackling noise. Now this is not my problem and I have never had a problem with it being like that.

But now, during mid-conversation, without me doing anything to my knowledge, it completely switched around but now my mic doesn't seem to register sound. Also the sound seems to now be surround sound instead of the normal sound I had before, sp00ky right?

So I have searched on the internet and on the turtle beach troubleshooting website yet I haven't found anything that can help me, I have also tried to see if it is a problem on the control panel but it doesn't seem to be recognizing my headset.

Just hope that someone knows about this problem and can help me, I really need to use my mic for RP and other things like Skype and TS. Thanks to anyone that tries to help in advance.

EDIT: Also I forgot to mention that when I speak through the mic, I can hear myself through the headset as usual and the computer can recognize when I plug the headset it and un-plug it, I just can't see the headset in the control panel.

Link to comment
  • Emerald

Well, I use the Turtle Beach Z22's which are designed for the PC. Yours are designed for the PS3 or 4. If your comp isn't recognizing your head set, that may be an issue with the USB port or the headset itself. But it shouldn't make a difference as that headset should work on the PC as well.

Link to comment
  • Sapphire

I used to have this headset and this problem as well! Try this http://www.turtlebeach.com/support/entry/830517289/

Link to comment

From your description it sounds like a hardware problem, on the other hand after your edit it also could be the software.

Have you done any changes to your system before all this happends?

First I would try to change USB port, try another one.

Then I would uninstall that device and reinstall it.

If the problem still occurs then its probably a hardware failure.

Carefully check the cable, is it streched loose in any way?

Last, check the guarantee and claim the same.

Link to comment

Well, I use the Turtle Beach Z22's which are designed for the PC. Yours are designed for the PS3 or 4. If your comp isn't recognizing your head set, that may be an issue with the USB port or the headset itself. But it shouldn't make a difference as that headset should work on the PC as well.

I realize that it is meant for PS3, I got it when I used to play PS3 and thought that PC gaming was lame, I was so young and stupid then. But I have used this for almost a year on my computer and have had no problems like this whatsoever thus far.

I used to have this headset and this problem as well! Try this http://www.turtlebeach.com/support/entry/830517289/

On the guide, it says one the recording tab "Right-click on "Turtle Beach USB Headset" and click "Set as Default Device", then click "OK."

Here is what I see when I click on that tab:

0dj7eOb.png

As you can see, there is no option for me that says "Turtle Beach Headset" or anything like that. Thanks for the help though.

Have you done any changes to your system before all this happends?

Nothing has to changed to my knowledge, I didn't change any settings, just suddenly changed when I was talking to someone on TS.

First I would try to change USB port, try another one.

I tried this already, still no luck, thanks for the suggestion though.

Then I would uninstall that device and reinstall it.

How would I do this exactly? When I go on "Devices and Sound" in the control panel I can not see anything title "Turtle Beach Headset" or anything along those lines.

Carefully check the cable, is it streched loose in any way?

It's all fine from what I can see, a bit tangled in places but everything is fine and properly plugged in.

Thanks to all three of you for trying to help, hopefully we can narrow this down and get it working again, I was thinking of buying a new headset anyways, could be a good excuse :P

Link to comment
  • Legend

Have you changed any settings on the PC?

When I got turtle beach I had to make the mic or headset itself as default in the PC settings.

(I just followed the instruction book in the box so not a complete expert :P )

Link to comment

Use the device manager, use search under start button and type in devmgmt.msc

Here you can see all your hardware devices, here you also can update your drivers for each device.

Check the USB handlers.

Plug in and out your PX21 and you will see if computer recognize it immediately.

Link to comment

Use the device manager, use search under start button and type in devmgmt.msc

Here you can see all your hardware devices, here you also can update your drivers for each device.

Check the USB handlers.

Plug in and out your PX21 and you will see if computer recognize it immediately.

Is it meant to update automatically when you plug-in/un-plug things? When I un-plug it, nothing happens, when I plug it in, nothing happens :/

Link to comment

Use the device manager, use search under start button and type in devmgmt.msc

Here you can see all your hardware devices, here you also can update your drivers for each device.

Check the USB handlers.

Plug in and out your PX21 and you will see if computer recognize it immediately.

Is it meant to update automatically when you plug-in/un-plug things? When I un-plug it, nothing happens, when I plug it in, nothing happens :/

When unplugged and then plugged in, you computer should immediately recognice it as a hardware device.

If it doesnt, either the USB port is faulty or the device it selfe.

Try connect the device to your PS3/4 station or another computer and see what happends.

ADDED:

Device should come up under your Sound, Video and Game devices as its own device. Pay special attention to that group in Device manager when trying.

Link to comment

ADDED:

Device should come up under your Sound, Video and Game devices as its own device. Play special attention to that group in Device manager when trying.

Nothing changes when I plug it in :(

Then my friend it really sounds like your device is faulty.

As said before check the guarantee and try claim the same, could work if not any fault on the cable.

Link to comment

From my beliefe that this is a hardware problem, in most cases it is the cable beeing streched.

Depending on how handy you are and if your warranty is active or not, you could open the cable case.

Inside you will find several smaller cables, one of those is loose or interuppted, either where your cable is "tangled" or at the cables end points.

It would be interesting to hear what Xiborg really think is the matter, as he asks for you to give him your device to "play around with it".

Link to comment

Personally I feel that it is a problem with the drivers from the device and nothing more, as you have said it is possible that it is a problem with the device itself, I would be able to check that if he gave me the headset also. I'd like to try using it on another machine firstly and also one that isn't windows 8 because I hate it. I doubt that it would be anything to do with the cable being stretched as normally they're pretty durable. I feel that if anything the problem lies in the area of the device where the microphone connects with the left ear muff since the sound still works.

Link to comment

Personally I feel that it is a problem with the drivers from the device and nothing more, as you have said it is possible that it is a problem with the device itself, I would be able to check that if he gave me the headset also. I'd like to try using it on another machine firstly and also one that isn't windows 8 because I hate it. I doubt that it would be anything to do with the cable being stretched as normally they're pretty durable. I feel that if anything the problem lies in the area of the device where the microphone connects with the left ear muff since the sound still works.

Thanks, you do have good points, now that you are showing a helping hand maybe you and the OP should have a talk on TS and together solve this irritating problem.

Link to comment

Personally I feel that it is a problem with the drivers from the device and nothing more, as you have said it is possible that it is a problem with the device itself, I would be able to check that if he gave me the headset also. I'd like to try using it on another machine firstly and also one that isn't windows 8 because I hate it. I doubt that it would be anything to do with the cable being stretched as normally they're pretty durable. I feel that if anything the problem lies in the area of the device where the microphone connects with the left ear muff since the sound still works.

Thanks, you do have good points, now that you are showing a helping hand maybe you and the OP should have a talk on TS and together solve this irritating problem.

Well, I didn't really make it clear by my original post or anything like that, I actually know JayDee in real life, I've spoken to him about it and it's well and truly broken :L

Link to comment

Personally I feel that it is a problem with the drivers from the device and nothing more, as you have said it is possible that it is a problem with the device itself, I would be able to check that if he gave me the headset also. I'd like to try using it on another machine firstly and also one that isn't windows 8 because I hate it. I doubt that it would be anything to do with the cable being stretched as normally they're pretty durable. I feel that if anything the problem lies in the area of the device where the microphone connects with the left ear muff since the sound still works.

Thanks, you do have good points, now that you are showing a helping hand maybe you and the OP should have a talk on TS and together solve this irritating problem.

Well, I didn't really make it clear by my original post or anything like that, I actually know JayDee in real life, I've spoken to him about it and it's well and truly broken :L

Np, its hard to troubleshoot at distance, good to hear that you as a friend is helping him out, do take a look at post #15 and maybe from there you together can save him some money.

Suggest solved.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...