Jump to content
Server time: 2017-08-23, 14:08

  • 0
Sign in to follow this  
Guest

Steam instantly crashing ?

Question

Guest   
Guest

Well, I had this issue for a while now (~1 month) but recently it gets really annoying.

Nearly everytime I open Steam it crashes after 5 to 10 seconds and rarely it just keeps running normally.

Does anyone have any solutions to this problem ? Normally I only manage to make it run normally after restarting my PC multiple times and that is obviously really annoying.

Share this post


Link to post
Share on other sites

25 answers to this question

Recommended Posts

  • 0
Guest Pandi   
Guest Pandi

Have you tried running it as administrator all the time?

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Have you tried running it as administrator all the time?

Yes, but that doesn't change anything...


Hmm. Is there a program in the background like an antivirus that might be conflicting with Steam?

I was also thinking about that and yes there is, I am currently trying to close the antivirus and run Steam.

EDIT: Just tried running it with my Antivirus closed but nothing changed...

Share this post


Link to post
Share on other sites
  • 0
Aj1080pGamer    0

Step 1: What Antivirus Software do you have? This might be the case where your Firewall is declining the Program, Reason being was a couple months ago Steam got there shit hacked into as a prank and all Antivirus programs after the event were set to defualt block. So... Go into your firewall and see if it's blocked, Somewhere in your antiviruse software you will see firewall and stuff. (Depends on the Software I can further help)

Step 2: Run as admin by right clicking going to properties and then Compatible and in there you will check the Run as Administrator.

Step 3: worst case you would need to un-install steam through windows and then reinstall but this seems to be the same issue I had about 1.5 months ago.....

Let me know what software you have for Antivirus and What Operating system your on 32bit or 64bit.

(Sorry for the grammer and spelling if there is I am on my phone at work)

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Step 1: What Antivirus Software do you have? This might be the case where your Firewall is declining the Program, Reason being was a couple months ago Steam got there shit hacked into as a prank and all Antivirus programs after the event were set to defualt block. So... Go into your firewall and see if it's blocked, Somewhere in your antiviruse software you will see firewall and stuff. (Depends on the Software I can further help)

Step 2: Run as admin by right clicking going to properties and then Compatible and in there you will check the Run as Administrator.

Step 3: worst case you would need to un-install steam through windows and then reinstall but this seems to be the same issue I had about 1.5 months ago.....

Let me know what software you have for Antivirus and What Operating system your on 32bit or 64bit.

(Sorry for the grammer and spelling if there is I am on my phone at work)

Just reinstalled Steam and I still have the same issue, so it probably has to do something with the firewall.

And I am currently using Avira and my Operating system is 64bit.

Share this post


Link to post
Share on other sites
  • 0
Aj1080pGamer    0

.................

Just reinstalled Steam and I still have the same issue, so it probably has to do something with the firewall.

And I am currently using Avira and my Operating system is 64bit.

Somewhere in that program will give you the option to change protocals for certian program to allow through the firewall and not. Try and see if you can find it. Somewhere in the firewall will show like Steam and it would have a check box or drop box that gives options on Allow, block, custom, auto. somthing like that, sorry on my phone so I am trying to help as much as possible.

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

.................

Just reinstalled Steam and I still have the same issue, so it probably has to do something with the firewall.

And I am currently using Avira and my Operating system is 64bit.

Somewhere in that program will give you the option to change protocals for certian program to allow through the firewall and not. Try and see if you can find it. Somewhere in the firewall will show like Steam and it would have a check box or drop box that gives options on Allow, block, custom, auto. somthing like that, sorry on my phone so I am trying to help as much as possible.

Yes, I found those protocols, but from what I can see no Steam file that is listed there is blocked or anything.

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

I have had this issue also.

Restart your computer and it should work. It did for me at least.

Share this post


Link to post
Share on other sites
  • 0
Aj1080pGamer    0

.......

If you have the option to add one add the Steam.exe from the Directory folder it is in and that should help also arcus might be right restarting can help.

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Just tried restarting it and that didn't change much either.

I'll go to bed now and try to solve the problem tomorrow, thanks for all the help so far guys, hopefully I'll manage to get rid of this issue...

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

If you have the option to add one add the Steam.exe from the Directory folder it is in and that should help also arcus might be right restarting can help.

Doing this helped me more or less. The last few times I tried to run Steam half of the time it just crashed like it did before and the other times it ran normally again but crashed again after some minutes....

Does anyone have some other tips maybe ?

Share this post


Link to post
Share on other sites
  • 0
Guest Vespah   
Guest Vespah

If you have the option to add one add the Steam.exe from the Directory folder it is in and that should help also arcus might be right restarting can help.

Doing this helped me more or less. The last few times I tried to run Steam half of the time it just crashed like it did before and the other times it ran normally again but crashed again after some minutes....

Does anyone have some other tips maybe ?

Try disabling your UAC:

Control Panel > Search Bar > Type UAC > Disable UAC.

Another suggestion is to disable Data Execution Prevention. This occurs when a program like steam is ran, your computer pickups an increase of memory being used incorrectly or being executed into the program and shuts a program down for safety purposes.

To disable DEP:

Open Command Promt and Run as Admin (Search: CMD > Right Click > Run as admin.

Paste the following (or type)

bcdedit.exe /set {current} nx AlwaysOff

Then restart your PC and try steam again

Hope that helps


As a side note to the above, how much RAM do you have?

Share this post


Link to post
Share on other sites
  • 0
Guest Vespah   
Guest Vespah

Is it fixed Franz?

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Not yet, was trying something else, couldn't try your tips atm, but need to go to bed now and will tell you asap ;)

And thanks for the help !

Share this post


Link to post
Share on other sites
  • 0
Guest Vespah   
Guest Vespah

Not yet, was trying something else, couldn't try your tips atm, but need to go to bed now and will tell you asap ;)

And thanks for the help !

Okay dude :)

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

-snip-

Didn't help me either :(, running out of solutions slowly.....wondering what this could be

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

-snip-

Didn't help me either :(, running out of solutions slowly.....wondering what this could be

Redownload the damn program!!! :)

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

-snip-

Didn't help me either :(, running out of solutions slowly.....wondering what this could be

Redownload the damn program!!! :)

Already did :P, twice.

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Already did :P, twice.

Have you tried yelling at it?

Share this post


Link to post
Share on other sites
  • 0
Guest   
Guest

Managed to solve the problem, this can be closed now.

And thanks for all the help guys ! :D

Share this post


Link to post
Share on other sites
  • 0
Guest Pandi   
Guest Pandi

Marking as solved and closing as requested, glad it's fixed!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×