Jump to content
Server time: 2017-10-20, 16:20
Safe Zone: OPEN

  • 0
Sign in to follow this  
DeadAntelope

Can hear myself through my headset

Question

So whilst my PC is being built I'm borrowing my brother's PC and so I've plugged in my headset. But for some reason I can hear myself through my right headset part but it is just noise so is really annoying.

Any help appreciated, thanks.

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

Some headsets have some sort of inbuilt thingy where you can hear yourself, so for example, when your volume is really loud, you don't start shouting because you can hear your own voice.

It may all be down to the actual microphone settings on the computer.

Share this post


Link to post
Share on other sites
  • 0
Alec    0

Anyways right click bottom right volum logo, click recording devices, find your microphone (usually has a tick on it), right click that, click properties, select "Listen" tab, untick "Listen to this Device".

If that doesn't work, what headset do you have? If they're turtle beaches then it's the feature Assassin mentioned.

Share this post


Link to post
Share on other sites
  • 0
Alec    0

So in "Recording devices" "Your mic properties" there is no listen tab? You sure?

TX5ByWY.png

Share this post


Link to post
Share on other sites
  • 0
x_kane_x188    0

I'm sure. I have all but the levels one.

You don't need the levels one, just the listen tab, take a screenshot of your properties tab open.

Share this post


Link to post
Share on other sites
  • 0
Alec    0

^^^^^^^

Yeh, the listen tab should have that setting, see the one that says listen to this device?

Share this post


Link to post
Share on other sites
  • 0

So in "Recording devices" "Your mic properties" there is no listen tab? You sure?

TX5ByWY.png

That may be it, untick the "listen to this device" if it's ticked.

Share this post


Link to post
Share on other sites
  • 0
Alec    0

That's weird man, can't help you there then. Sorry, maybe try googling it?

Share this post


Link to post
Share on other sites
  • 0
   5

You can hear it constantly? Also does your brothers PC have any drivers or something that have more settings for audio? Perhaps it comes from there.

(message me later, I've had this problem afew times the fix is normally easy^^)

Share this post


Link to post
Share on other sites
  • 0
VaneKyle    0

If there is no listen tab go into settings of default sound device. If you're lucky there's a option concerning microphone in there which you need to turn off(do not know the name of the option).

Going to see if I can find it.

EDIT: Called something along the lines of "Microphone FP".

Share this post


Link to post
Share on other sites
  • 0

@Mex No, not constantly but it happens when I make a loud noise. I wouldn't know about the drivers thing.

@Vane I couldn't find that but I went into my speakers and saw that it was playing back my mic so I turned it off and hey presto! No more noise!

Share this post


Link to post
Share on other sites
  • 0
VaneKyle    0

@Mex No, not constantly but it happens when I make a loud noise. I wouldn't know about the drivers thing.

@Vane I couldn't find that but I went into my speakers and saw that it was playing back my mic so I turned it off and hey presto! No more noise!

Please, call me Jesus.

tumblr_m3bzc40g2o1r1awtfo1_250.gif

Was it in Mixer or settings?

Never had this problem only heard of it :)

EDIT: VaneKyle4Staff

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×